Database di formeDatabase di forme
Il database Shape funge da archivio locale di uso generale per modelli CAD 3D. Le voci nel database Shape sono memorizzate come mesh 3D (o forme) e possono rappresentare, ad esempio, la superficie irregolare di un materiale ottenuto da misurazioni AFM, il complesso contatto esagonale su un dispositivo ad ampia superficie (vedere ??) o i pilastri periodici di un cristallo fotonico. Le forme sono definite utilizzando mesh triangolari. La finestra del database Shape include strumenti per generare nuovi modelli CAD 3D da immagini 2D, nonché per importare mesh esterne da file Wavefront OBJ. Fondamentalmente, tutte le forme in questo database sono memorizzate in modo permanente su disco e sono destinate a rappresentare geometrie più complesse rispetto a quelle generate dall'editor di mesh, che si concentra su semplici elementi geometrici come cubi, tubi e sfere (vedere CAD Meshes).Il database Shape funge da archivio locale di uso generale per modelli CAD 3D. Le voci nel database Shape sono memorizzate come mesh 3D (o forme) e possono rappresentare, ad esempio, la superficie irregolare di un materiale ottenuto da misurazioni AFM, il complesso contatto esagonale su un dispositivo ad ampia superficie (vedere ??) o i pilastri periodici di un cristallo fotonico. Le forme sono definite utilizzando mesh triangolari. La finestra del database Shape include strumenti per generare nuovi modelli CAD 3D da immagini 2D, nonché per importare mesh esterne da file Wavefront OBJ. Fondamentalmente, tutte le forme in questo database sono memorizzate in modo permanente su disco e sono destinate a rappresentare geometrie più complesse rispetto a quelle generate dall'editor di mesh, che si concentra su semplici elementi geometrici come cubi, tubi e sfere (vedere CAD Meshes).
Accesso al database.Accesso al database.
Le forme vengono memorizzate nel database delle forme, a cui è possibile accedere tramite la scheda «Database» facendo clic sull’icona «Forme» (vedere ??). Cliccando sull’icona del database delle forme si apre la finestra del database delle forme (??).Le forme vengono memorizzate nel database delle forme, a cui è possibile accedere tramite la scheda «Database» facendo clic sull’icona «Forme» (vedere ??). Cliccando sull’icona del database delle forme si apre la finestra del database delle forme (??).
Provate ad aprire alcune delle forme per esaminarle. Vedrete una finestra simile a quella mostrata in ??. Questo esempio illustra la struttura a nido d’ape di un contatto di una cella solare. A sinistra è visibile la forma tridimensionale, mentre a destra è presente l’immagine bidimensionale utilizzata per generarla. Sovrapposta all’immagine bidimensionale è presente una proiezione zx della griglia tridimensionale. Potete attivare e disattivare questa griglia bidimensionale tramite il pulsante «Mostra griglia» che si trova nella barra degli strumenti in alto.Provate ad aprire alcune delle forme per esaminarle. Vedrete una finestra simile a quella mostrata in ??. Questo esempio illustra la struttura a nido d’ape di un contatto di una cella solare. A sinistra è visibile la forma tridimensionale, mentre a destra è presente l’immagine bidimensionale utilizzata per generarla. Sovrapposta all’immagine bidimensionale è presente una proiezione zx della griglia tridimensionale. Potete attivare e disattivare questa griglia bidimensionale tramite il pulsante «Mostra griglia» che si trova nella barra degli strumenti in alto.
Creazione di una griglia.Creazione di una griglia.
Una volta aperta la finestra del database delle forme, è possibile visualizzare e modificare qualsiasi forma salvata. Molte delle forme presenti nel database sono state create originariamente a partire da immagini 2D utilizzando gli strumenti di discretizzazione integrati. In questa sezione viene spiegato come funziona questo processo. Aprire morphology/1 nel database delle forme. Verrà visualizzata una finestra simile a ??. Il pannello a sinistra mostra la griglia triangolare 3D risultante, mentre il pannello a destra visualizza l’immagine 2D originale da cui è stata generata la griglia. Il pulsante «Mostra griglia» nella barra degli strumenti «File» attiva o disattiva la sovrapposizione della griglia sull’immagine 2D, consentendo di esaminare come la triangolazione segue le caratteristiche sottostanti.Una volta aperta la finestra del database delle forme, è possibile visualizzare e modificare qualsiasi forma salvata. Molte delle forme presenti nel database sono state create originariamente a partire da immagini 2D utilizzando gli strumenti di discretizzazione integrati. In questa sezione viene spiegato come funziona questo processo. Aprire morphology/1 nel database delle forme. Verrà visualizzata una finestra simile a ??. Il pannello a sinistra mostra la griglia triangolare 3D risultante, mentre il pannello a destra visualizza l’immagine 2D originale da cui è stata generata la griglia. Il pulsante «Mostra griglia» nella barra degli strumenti «File» attiva o disattiva la sovrapposizione della griglia sull’immagine 2D, consentendo di esaminare come la triangolazione segue le caratteristiche sottostanti.
Per modificare il modo in cui l’immagine viene convertita in una mesh 3D, fare clic su «Modifica mesh» nella barra multifunzione «File». Si aprirà la finestra di dialogo di configurazione della mesh (??), che consente di controllare il livello di discretizzazione.Per modificare il modo in cui l’immagine viene convertita in una mesh 3D, fare clic su «Modifica mesh» nella barra multifunzione «File». Si aprirà la finestra di dialogo di configurazione della mesh (??), che consente di controllare il livello di discretizzazione.
I parametri principali sono:I parametri principali sono:
- x-triangoli: numero massimo di triangoli lungo la direzione orizzontale.x-triangoli: numero massimo di triangoli lungo la direzione orizzontale.
- triangoli lungo l’asse verticale — numero massimo di triangoli disposti lungo la direzione verticaletriangoli lungo l’asse verticale — numero massimo di triangoli disposti lungo la direzione verticale
- Metodo: consente di selezionare il modo in cui viene creata la griglia.Metodo: consente di selezionare il modo in cui viene creata la griglia.
- Angolo minimo consentito: impedisce la formazione di triangoli estremamente sottili e instabili.Angolo minimo consentito: impedisce la formazione di triangoli estremamente sottili e instabili.
A titolo di esempio, riducete sia i triangoli lungo l’asse x che quelli lungo l’asse y a 40, quindi fate clic su «Crea mesh». La mesh risultante conterrà un numero inferiore di triangoli e sarà quindi meno dettagliata, ma più rapida da elaborare. Questa riduzione è immediatamente visibile nelle anteprime 2D e 3D.A titolo di esempio, riducete sia i triangoli lungo l’asse x che quelli lungo l’asse y a 40, quindi fate clic su «Crea mesh». La mesh risultante conterrà un numero inferiore di triangoli e sarà quindi meno dettagliata, ma più rapida da elaborare. Questa riduzione è immediatamente visibile nelle anteprime 2D e 3D.
L’impostazione «Metodo» determina il modo in cui vengono generati i triangoli:L’impostazione «Metodo» determina il modo in cui vengono generati i triangoli:
- Nessuna riduzione: genera una griglia triangolare uniforme e regolare. Questo approccio offre la geometria più precisa, ma comporta la creazione di un numero elevato di triangoli.Nessuna riduzione: genera una griglia triangolare uniforme e regolare. Questo approccio offre la geometria più precisa, ma comporta la creazione di un numero elevato di triangoli.
- Riduzione dei nodi: si parte da una griglia regolare e si eliminano poi i punti superflui per ridurre il numero di triangoli, mantenendo al contempo la forma generale.Riduzione dei nodi: si parte da una griglia regolare e si eliminano poi i punti superflui per ridurre il numero di triangoli, mantenendo al contempo la forma generale.
Passando all’opzione «No reduce» e ricostruendo la griglia, si sostituirà la griglia adattiva con una triangolazione completa e regolare 70 × 70. Questo approccio è più preciso, ma richiede anche più spazio di archiviazione e potenza di calcolo per la simulazione. Ogni triangolo aggiuntivo in una griglia comporta un maggiore carico computazionale durante la simulazione. Pertanto, l’obiettivo nella creazione di una griglia è rappresentare la forma utilizzando il minor numero possibile di triangoli. Se è possibile descrivere un’intera superficie con un numero relativamente piccolo di triangoli, di solito conviene farlo. Tuttavia, per forme molto regolari, l’applicazione dell’opzione «Node reduce» per ridurre il numero di triangoli potrebbe offrire pochi o nessun vantaggio; in questi casi, una semplice griglia regolare può essere altrettanto efficace. In pratica, sarà spesso necessario sperimentare con diverse impostazioni e metodi per trovare una griglia che offra un equilibrio accettabile tra precisione e costo computazionale.Passando all’opzione «No reduce» e ricostruendo la griglia, si sostituirà la griglia adattiva con una triangolazione completa e regolare 70 × 70. Questo approccio è più preciso, ma richiede anche più spazio di archiviazione e potenza di calcolo per la simulazione. Ogni triangolo aggiuntivo in una griglia comporta un maggiore carico computazionale durante la simulazione. Pertanto, l’obiettivo nella creazione di una griglia è rappresentare la forma utilizzando il minor numero possibile di triangoli. Se è possibile descrivere un’intera superficie con un numero relativamente piccolo di triangoli, di solito conviene farlo. Tuttavia, per forme molto regolari, l’applicazione dell’opzione «Node reduce» per ridurre il numero di triangoli potrebbe offrire pochi o nessun vantaggio; in questi casi, una semplice griglia regolare può essere altrettanto efficace. In pratica, sarà spesso necessario sperimentare con diverse impostazioni e metodi per trovare una griglia che offra un equilibrio accettabile tra precisione e costo computazionale.
Strumenti per la generazione e la modifica di immagini 2DStrumenti per la generazione e la modifica di immagini 2D
Oltre alla possibilità di caricare immagini da file, l’editor di forme contiene una serie di strumenti per generare nuovi modelli 2D che possono essere convertiti in mesh 3D. Questi strumenti sono disponibili nella scheda «Immagine 2D» e includono generatori per un’ampia gamma di strutture:Oltre alla possibilità di caricare immagini da file, l’editor di forme contiene una serie di strumenti per generare nuovi modelli 2D che possono essere convertiti in mesh 3D. Questi strumenti sono disponibili nella scheda «Immagine 2D» e includono generatori per un’ampia gamma di strutture:
- Motivi a nido d’ape per la disposizione dei pixel o per le griglie di elettrodiMotivi a nido d’ape per la disposizione dei pixel o per le griglie di elettrodi
- Reticoli di cristalli fotonici con periodicità configurabileReticoli di cristalli fotonici con periodicità configurabile
- Lenti definite tramite mappe di altezza.Lenti definite tramite mappe di altezza.
- Profili gaussiani per rilievi, avvallamenti o superfici a gradiente.Profili gaussiani per rilievi, avvallamenti o superfici a gradiente.
- Funzioni che descrivono l’altezza delle onde (vedi l’esempio qui sotto)Funzioni che descrivono l’altezza delle onde (vedi l’esempio qui sotto)
- Motivi a scacchiera per la calibrazione e i testMotivi a scacchiera per la calibrazione e i test
- Rumore di Perlin per la generazione di una rugosità superficiale realistica.Rumore di Perlin per la generazione di una rugosità superficiale realistica.
Ogni generatore offre le proprie opzioni di configurazione, consentendo di personalizzare la geometria prima di convertirla in una mesh. Queste immagini fungono da mappe di altezza o maschere, a partire dalle quali l’editor di forme crea la corrispondente struttura 3D.Ogni generatore offre le proprie opzioni di configurazione, consentendo di personalizzare la geometria prima di convertirla in una mesh. Queste immagini fungono da mappe di altezza o maschere, a partire dalle quali l’editor di forme crea la corrispondente struttura 3D.
Dopo aver generato o caricato un’immagine, la scheda «Filtri» offre strumenti per modificarla prima di procedere alla creazione della mesh. Tra questi troviamo:Dopo aver generato o caricato un’immagine, la scheda «Filtri» offre strumenti per modificarla prima di procedere alla creazione della mesh. Tra questi troviamo:
- Effetto sfocatura: attenua il rumore o le transizioni brusche.Effetto sfocatura: attenua il rumore o le transizioni brusche.
- Normalizza (x, y, z): ridimensiona l’immagine in ogni direzione.Normalizza (x, y, z): ridimensiona l’immagine in ogni direzione.
- Soglia: converte l’immagine in una maschera binaria (l’esempio è mostrato sopra).Soglia: converte l’immagine in una maschera binaria (l’esempio è mostrato sopra).
- Ruota: ruota il motivo di un angolo fisso o variabile.Ruota: ruota il motivo di un angolo fisso o variabile.
- Rilevamento bordi: evidenzia o estrae i contorni all’interno dell’immagine.Rilevamento bordi: evidenzia o estrae i contorni all’interno dell’immagine.
Questi strumenti consentono di perfezionare le mappe di altezza, correggere immagini con rumore o modificare i pattern prima di generare la griglia triangolare finale. La combinazione di generatori di immagini e filtri offre un flusso di lavoro flessibile per creare geometrie 3D complesse e personalizzate direttamente all’interno di OghmaNano.Questi strumenti consentono di perfezionare le mappe di altezza, correggere immagini con rumore o modificare i pattern prima di generare la griglia triangolare finale. La combinazione di generatori di immagini e filtri offre un flusso di lavoro flessibile per creare geometrie 3D complesse e personalizzate direttamente all’interno di OghmaNano.
Importazione da file CADImportazione da file CAD
Oltre a generare forme a partire da immagini 2D, l’editor di forme consente anche di importare modelli 3D esterni utilizzando il pulsante «Importa file CAD» visualizzato in ??. OghmaNano supporta il formato Wavefront OBJ, ampiamente utilizzato per memorizzare modelli di superfici triangolate. Nel database delle forme è disponibile anche un esempio di modello CAD importato: il classico Utah Teapot, visualizzato in ??. Questo modello illustra l’aspetto dei modelli triangolati esterni una volta importati nell’editor.Oltre a generare forme a partire da immagini 2D, l’editor di forme consente anche di importare modelli 3D esterni utilizzando il pulsante «Importa file CAD» visualizzato in ??. OghmaNano supporta il formato Wavefront OBJ, ampiamente utilizzato per memorizzare modelli di superfici triangolate. Nel database delle forme è disponibile anche un esempio di modello CAD importato: il classico Utah Teapot, visualizzato in ??. Questo modello illustra l’aspetto dei modelli triangolati esterni una volta importati nell’editor.
Quando si importano modelli CAD, è importante assicurarsi che la mesh formi una superficie chiusa. Una superficie chiusa è una superficie in cui ogni spigolo appartiene esattamente a due triangoli, creando un volume completamente sigillato e impermeabile. Le superfici aperte, le facce mancanti o le fessure generano ambiguità nel determinare se i punti si trovano all’interno o all’esterno dell’oggetto, il che le rende inadatte alla simulazione.Quando si importano modelli CAD, è importante assicurarsi che la mesh formi una superficie chiusa. Una superficie chiusa è una superficie in cui ogni spigolo appartiene esattamente a due triangoli, creando un volume completamente sigillato e impermeabile. Le superfici aperte, le facce mancanti o le fessure generano ambiguità nel determinare se i punti si trovano all’interno o all’esterno dell’oggetto, il che le rende inadatte alla simulazione.
Le mesh CAD sono generalmente progettate per la lavorazione meccanica e la produzione, e non per la simulazione numerica. Di conseguenza, spesso contengono un numero di triangoli molto superiore a quello necessario per la modellazione ottica o fisica. Un elevato numero di triangoli aumenta notevolmente il tempo di calcolo nel ray tracing e in altri algoritmi di calcolo.Le mesh CAD sono generalmente progettate per la lavorazione meccanica e la produzione, e non per la simulazione numerica. Di conseguenza, spesso contengono un numero di triangoli molto superiore a quello necessario per la modellazione ottica o fisica. Un elevato numero di triangoli aumenta notevolmente il tempo di calcolo nel ray tracing e in altri algoritmi di calcolo.
Per ottenere le migliori prestazioni, assicurarsi che le mesh importate:Per ottenere le migliori prestazioni, assicurarsi che le mesh importate:
- formare una superficie completamente chiusa e impermeabile.formare una superficie completamente chiusa e impermeabile.
- contengono solo il numero di triangoli necessario per rappresentare la geometria econtengono solo il numero di triangoli necessario per rappresentare la geometria e
- eliminare eventuali imperfezioni o tracce di lavorazione superflue.eliminare eventuali imperfezioni o tracce di lavorazione superflue.
Seguendo queste istruzioni, si contribuirà a garantire che le geometrie CAD importate funzionino correttamente all’interno di OghmaNano.Seguendo queste istruzioni, si contribuirà a garantire che le geometrie CAD importate funzionino correttamente all’interno di OghmaNano.
Il formato di file vettorialeIl formato di file vettoriale
Una forma deve delimitare un volume completamente chiuso. Se si utilizza la funzione integrata per la discretizzazione delle forme, questa condizione viene applicata automaticamente. Tuttavia, se si creano le forme manualmente, è necessario assicurarsi che il volume sia chiuso.Una forma deve delimitare un volume completamente chiuso. Se si utilizza la funzione integrata per la discretizzazione delle forme, questa condizione viene applicata automaticamente. Tuttavia, se si creano le forme manualmente, è necessario assicurarsi che il volume sia chiuso.
Ogni cartella contenente le forme include i seguenti file:Ogni cartella contenente le forme include i seguenti file:
| Nome del fileNome del file | DescrizioneDescrizione | |
|---|---|---|
| \(data.json\)\(data.json\) | Dati di configurazione per la forma.Dati di configurazione per la forma. | |
| \(image\_original.png\)\(image\_original.png\) | Copia di backup dell’immagine importata.Copia di backup dell’immagine importata. | |
| \(image\_out.png\)\(image\_out.png\) | L’immagine finale, dopo l’elaborazione.L’immagine finale, dopo l’elaborazione. | |
| \(image.png\)\(image.png\) | La copia di lavoro dell’immagine importata.La copia di lavoro dell’immagine importata. | |
| \(shape.inp\)\(shape.inp\) | La griglia tridimensionale discretizzata della forma.La griglia tridimensionale discretizzata della forma. |
I file PNG rappresentano l’immagine nelle diverse fasi di elaborazione. Il file data.json memorizza la configurazione dell’editor di forme, mentre il file shape.inp contiene la struttura tridimensionale dell’oggetto.I file PNG rappresentano l’immagine nelle diverse fasi di elaborazione. Il file data.json memorizza la configurazione dell’editor di forme, mentre il file shape.inp contiene la struttura tridimensionale dell’oggetto.
Un esempio di file shape.inp è mostrato in ??. Il formato è progettato in modo che gnuplot possa aprirlo direttamente utilizzando il comando splot. Ogni triangolo è descritto da quattro punti z, x, y: le prime tre righe definiscono il triangolo e la quarta ripete il primo punto, in modo che gnuplot possa disegnare un contorno chiuso. Il numero di triangoli presenti nel file è indicato in una riga che inizia con #y.Un esempio di file shape.inp è mostrato in ??. Il formato è progettato in modo che gnuplot possa aprirlo direttamente utilizzando il comando splot. Ogni triangolo è descritto da quattro punti z, x, y: le prime tre righe definiscono il triangolo e la quarta ripete il primo punto, in modo che gnuplot possa disegnare un contorno chiuso. Il numero di triangoli presenti nel file è indicato in una riga che inizia con #y.
I valori esatti di z, x, y non sono rilevanti. Non appena la forma viene caricata, tutti i valori vengono normalizzati in modo che il punto più basso della forma si trovi in (0, 0, 0) e il punto più alto in (1, 1, 1). Quando la forma viene inserita in una scena, viene nuovamente normalizzata per raggiungere le dimensioni fisiche desiderate dell’oggetto nel dispositivo.I valori esatti di z, x, y non sono rilevanti. Non appena la forma viene caricata, tutti i valori vengono normalizzati in modo che il punto più basso della forma si trovi in (0, 0, 0) e il punto più alto in (1, 1, 1). Quando la forma viene inserita in una scena, viene nuovamente normalizzata per raggiungere le dimensioni fisiche desiderate dell’oggetto nel dispositivo.
shape.inp. Ogni triangolo è definito da quattro punti z, x, y e può essere visualizzato direttamente utilizzando gnuplot.Un esempio di file shape.inp. Ogni triangolo è definito da quattro punti z, x, y e può essere visualizzato direttamente utilizzando gnuplot.👉 Passaggio successivo: per un esempio pratico di come generare forme, consultare il tutorial sul database delle forme e su come creare forme 3D a partire da immagini, disponibile al seguente link: questo link.👉 Passaggio successivo: per un esempio pratico di come generare forme, consultare il tutorial sul database delle forme e su come creare forme 3D a partire da immagini, disponibile al seguente link: questo link.