Startseite Beispiele Screenshots Benutzerhandbuch Bluesky-Logo YouTube ☰
OghmaNano Simulation von organischen/Perowskit-Solarzellen, OFETs und OLEDs DOWNLOAD Quick Start guide

Raytracing-Tutorial (Teil E): Materialien und die Welt-Box

In diesem letzten Teil werden wir unsere einfache Raytracing-Umgebung fertigstellen, indem wir zunächst das optische Material der Teekanne verändern und anschließend den Weltraum darstellen, der die Grenzen der Simulation definiert. Am Ende sollten Sie in der Lage sein, sowohl die Geometrie als auch die Materialien zu bearbeiten und zu wissen, wie weit Sie Objekte bewegen können, bevor sie außerhalb der simulierten Welt liegen.

Schritt 1: Ändern Sie das Material der Teekanne.

Beginnen Sie mit der in Teil D erstellten Szene, in der die Teekanne bereits aus der Formdatenbank importiert und im Strahl platziert wurde. Klicken Sie mit der rechten Maustaste direkt auf das Teekannen-Mesh und wählen Sie im Kontextmenü die Option „Objekt bearbeiten“. Dadurch wird der allgemeine Objekt-Editor geöffnet, der in ?? dargestellt ist.

Optical Workbench view with the teapot selected and the Edit object menu item highlighted
Klicken Sie mit der rechten Maustaste auf die Teekanne und wählen Sie „Objekt bearbeiten“, um den Objekteditor zu öffnen.
Object editor window for the teapot, showing the Optical material field with glasses/flint/BAF10.yml
Der Objekt-Editor für die Teekanne. Unter „Optisch“ können Sie die Daten für den Brechungsindex (optisches Material) auswählen, die beim Raytracing verwendet werden.

Im Register „Objekt“ des Editors können Sie die Position, Rotation und Farbe der Teekanne einsehen. Für diesen Schritt benötigen wir nur den Abschnitt „Optik“ am unteren Rand:

  1. Suchen Sie das Feld „Optisches Material“.
  2. Klicken Sie auf die Schaltfläche mit den drei Punkten daneben.
  3. Wählen Sie im sich öffnenden Dateiauswahldialog das Material glasses/flint/BAF10.yml aus.
  4. Klicken Sie auf „Öffnen“, um die Auswahl zu bestätigen, und schließen Sie anschließend das Fenster des Objekteditors.

Die Teekanne verwendet nun das hochbrechende Flintglas BAF10 aus der optischen Datenbank. Wenn Sie die Simulation erneut ausführen, werden die Lichtstrahlen stärker gebrochen, wenn sie in die Teekanne eintreten und diese verlassen, als bei einem Material mit einem niedrigeren Brechungsindex.

Klicken Sie. Simulation starten (oder drücken Sie) F9). Nachdem die Raytracing-Berechnung abgeschlossen ist, sollten Sie etwas Ähnliches wie das Folgende sehen: ??wobei die Lichtstrahlen in den Teekannen-Körper eindringen, im Inneren gebrochen werden und auf der gegenüberliegenden Seite wieder austreten.

Ray-tracing scene with rays passing through the lens, aperture and teapot before reaching the detector
Nachdem das BAF10-Glas der Teekanne zugewiesen wurde, wird eine Raytracing-Berechnung durchgeführt. Die Lichtstrahlen werden nun innerhalb der Teekanne gebrochen, bevor sie diese verlassen und sich zum Detektor bewegen.

Schritt 2: Zeigen Sie das Weltfenster an.

Jedes Objekt in der Szene befindet sich innerhalb einer begrenzten Weltbox. Diese Box definiert den Bereich, innerhalb dessen der Raytracer erwartet, Objekte zu finden. Strahlen, die mit Objekten außerhalb dieses Bereichs interagieren, können ignoriert werden oder dazu führen, dass die Simulation eine Fehlermeldung bezüglich ungültiger Geometrie ausgibt.

Um die Weltkiste zu veranschaulichen:

  1. Klicken Sie mit der rechten Maustaste auf eine beliebige Stelle in einem leeren Bereich (nicht auf ein Objekt) in der Ansicht „Optical Workbench“.
  2. Wählen Sie im Kontextmenü „Ansicht“ > „Optisch“ > „Weltrahmen anzeigen“, wie in ?? dargestellt.
Context menu opened in the Optical Workbench view with View > Optical > Show world box highlighted
Das Menü „Ansicht“. Aktivieren Sie die Option „Weltbereich anzeigen“, um die äußere Simulationsgrenze darzustellen.
Optical Workbench scene with a large red wireframe box surrounding the lens, aperture, teapot and detector
Die Weltansicht wurde als rotes Drahtgitterwürfel dargestellt, der das optische System umschloss. Normalerweise sollten sich alle Strahlen und Objekte innerhalb dieser Region befinden.

Sobald die Funktion aktiviert ist, erscheint ein großes, rotes Drahtgittermodell in Form eines Würfels (oder einer rechteckigen Box), das Ihr optisches System umschließt, wie in ?? dargestellt. Sie können Objekte weiterhin frei bewegen und drehen, aber wenn Sie sie weit außerhalb dieser Box verschieben:

Um die Größe des Weltbereichs zu ändern, verwenden Sie die Steuerung im linken Bedienfeld mit der Bezeichnung „Substrat xz-Größe“. Diese definiert die laterale Ausdehnung der virtuellen Welt in der x-z-Ebene. Wenn Sie diesen Wert erhöhen, erhalten Sie mehr Platz, um Objekte zu platzieren, während eine Verringerung den Fokus der Simulation auf einen kleineren Bereich um das optische System lenkt.

👏 Das war alles! Sie haben die Einführungsserie zum Thema Raytracing abgeschlossen. Sie haben gelernt, wie man Szenen lädt, Modelle und Linsen bearbeitet, Detektoren verschiebt, CAD-Formen hinzufügt, optische Materialien zuweist und die Weltbox visualisiert. Von hier aus können Sie mit denselben Werkzeugen beginnen, realistischere optische Systeme zu entwickeln, wie z. B. einfache Kameras oder Beleuchtungsanordnungen.