Home Esempi Immagini dello schermo Manuale utente Logo di Bluesky YouTube ☰
OghmaNano Piattaforma di simulazione multifisica per dispositivi optoelettronici e sistemi fotonici SCARICA Guida rapida per iniziare.

Effetti speciali cinematografici (Parte A): il ray tracing da una superficie irregolareEffetti speciali cinematografici (Parte A): il ray tracing da una superficie irregolare

L’esempio del modello «Escape from film» simula la luce emessa all’interno di una sottile pellicola semiconduttrice e calcola quanta di questa luce riesce a fuoriuscire attraverso la superficie superiore. Questo è rilevante per molti sistemi, come gli OLED, i LED e altre strutture emettitrici di luce, in cui l’emissione della luce è limitata dalla riflessione interna totale e dalla rugosità della superficie.L’esempio del modello «Escape from film» simula la luce emessa all’interno di una sottile pellicola semiconduttrice e calcola quanta di questa luce riesce a fuoriuscire attraverso la superficie superiore. Questo è rilevante per molti sistemi, come gli OLED, i LED e altre strutture emettitrici di luce, in cui l’emissione della luce è limitata dalla riflessione interna totale e dalla rugosità della superficie.

Fase 1: Crea una nuova simulazione di ray tracing.Fase 1: Crea una nuova simulazione di ray tracing.

Avvia OghmaNano e fai clic su «Nuova simulazione». Si aprirà la finestra «Nuova simulazione», come mostrato in ??. Fai doppio clic sulla voce «Ray tracing», evidenziata in ??.Avvia OghmaNano e fai clic su «Nuova simulazione». Si aprirà la finestra «Nuova simulazione», come mostrato in ??. Fai doppio clic sulla voce «Ray tracing», evidenziata in ??.

OghmaNano New simulation window with different device categories including ray tracing.
Nuova finestra di simulazione. Seleziona «Ray tracing» dall’elenco delle categorie di esempio.Nuova finestra di simulazione. Seleziona «Ray tracing» dall’elenco delle categorie di esempio.
Ray tracing examples list, with Escape from film highlighted.
All’interno della categoria «Ray tracing», seleziona «Escape from film». Quando richiesto, salva la simulazione in una cartella in cui hai i permessi di scrittura.All’interno della categoria «Ray tracing», seleziona «Escape from film». Quando richiesto, salva la simulazione in una cartella in cui hai i permessi di scrittura.

Fase 2: Verificare la struttura iniziale.Fase 2: Verificare la struttura iniziale.

Dopo aver aperto l’esempio, la finestra principale di OghmaNano mostra la struttura del dispositivo, come illustrato in ??. La scena contiene:Dopo aver aperto l’esempio, la finestra principale di OghmaNano mostra la struttura del dispositivo, come illustrato in ??. La scena contiene:

Utilizzare il pulsante sinistro del mouse per ruotare l’immagine e la rotellina del mouse per eseguire lo zoom fino a ottenere la visualizzazione mostrata in ??.Utilizzare il pulsante sinistro del mouse per ruotare l’immagine e la rotellina del mouse per eseguire lo zoom fino a ottenere la visualizzazione mostrata in ??.

Initial Escape from film simulation window showing semiconductor, oxide and detector grid.
La scena iniziale del film «Escape from». Uno strato di semiconduttore grezzo (rosso) è posizionato su uno strato di ossido liscio (grigio), con una griglia di rilevamento (viola) sopra la struttura.La scena iniziale del film «Escape from». Uno strato di semiconduttore grezzo (rosso) è posizionato su uno strato di ossido liscio (grigio), con una griglia di rilevamento (viola) sopra la struttura.
Rotated view of the Escape from film structure.
Ruotando la visuale, si può osservare la struttura tridimensionale completa e il piano del rivelatore posto sopra lo strato superficiale del film.Ruotando la visuale, si può osservare la struttura tridimensionale completa e il piano del rivelatore posto sopra lo strato superficiale del film.

Fase 3: Mostrare le sorgenti luminose integrate.Fase 3: Mostrare le sorgenti luminose integrate.

Per impostazione predefinita, il semiconduttore e l’ossido vengono visualizzati come oggetti pieni. Per visualizzare la posizione delle sorgenti luminose:Per impostazione predefinita, il semiconduttore e l’ossido vengono visualizzati come oggetti pieni. Per visualizzare la posizione delle sorgenti luminose:

  1. Fare clic con il pulsante destro del mouse sull’oggetto «Semiconduttore».Fare clic con il pulsante destro del mouse sull’oggetto «Semiconduttore».
  2. Dal menu contestuale, selezionate Visualizza → Mostra oggetti pieni e deselezionate l’opzione.Dal menu contestuale, selezionate Visualizza → Mostra oggetti pieni e deselezionate l’opzione.
  3. Ripetere la procedura per l’oggetto «Ossido».Ripetere la procedura per l’oggetto «Ossido».

Il percorso del menu è illustrato in ??. Una volta disattivati entrambi gli oggetti solidi, si dovrebbe visualizzare una nuvola di piccole frecce all’interno dell’immagine, come mostrato in ??. Queste frecce rappresentano le sorgenti luminose utilizzate per il ray tracing.Il percorso del menu è illustrato in ??. Una volta disattivati entrambi gli oggetti solidi, si dovrebbe visualizzare una nuvola di piccole frecce all’interno dell’immagine, come mostrato in ??. Queste frecce rappresentano le sorgenti luminose utilizzate per il ray tracing.

Context menu showing View > Show solid option for the semiconductor layer.
Fare clic con il pulsante destro del mouse sul semiconduttore o sull’ossido, quindi utilizzare il comando Visualizza → Mostra riempimento solido per attivare o disattivare la visualizzazione con ombreggiatura solida. Deselezionando questa opzione, gli oggetti diventano trasparenti.Fare clic con il pulsante destro del mouse sul semiconduttore o sull’ossido, quindi utilizzare il comando Visualizza → Mostra riempimento solido per attivare o disattivare la visualizzazione con ombreggiatura solida. Deselezionando questa opzione, gli oggetti diventano trasparenti.
Escape from film structure with solids hidden, exposing the embedded light sources as arrows.
Una volta nascosti gli elementi solidi, le sorgenti di radiazioni interne diventano visibili sotto forma di una serie di frecce incorporate nel film semiconduttore.Una volta nascosti gli elementi solidi, le sorgenti di radiazioni interne diventano visibili sotto forma di una serie di frecce incorporate nel film semiconduttore.

Ogni freccia rappresenta un gruppo di raggi emessi da quel punto. Cliccando con il tasto destro sull’oggetto che rappresenta la sorgente luminosa, sarà possibile modificare in seguito il numero di raggi, l’angolo di emissione e le dimensioni XY della sorgente. Torneremo su questo argomento nella Parte B.Ogni freccia rappresenta un gruppo di raggi emessi da quel punto. Cliccando con il tasto destro sull’oggetto che rappresenta la sorgente luminosa, sarà possibile modificare in seguito il numero di raggi, l’angolo di emissione e le dimensioni XY della sorgente. Torneremo su questo argomento nella Parte B.

Fase 4: avviare la simulazione di ray tracing.Fase 4: avviare la simulazione di ray tracing.

Fare clic su «Esegui simulazione» (icona blu a forma di pulsante di riproduzione) per avviare il programma di ray tracing. Dopo un breve periodo di tempo, la finestra si riempirà di raggi, come mostrato in ??. I raggi si diffondono all’interno del semiconduttore irregolare e o fuoriescono verso il rivelatore, oppure si disperdono nel substrato.Fare clic su «Esegui simulazione» (icona blu a forma di pulsante di riproduzione) per avviare il programma di ray tracing. Dopo un breve periodo di tempo, la finestra si riempirà di raggi, come mostrato in ??. I raggi si diffondono all’interno del semiconduttore irregolare e o fuoriescono verso il rivelatore, oppure si disperdono nel substrato.

Per analizzare come i percorsi dei raggi dipendono dalla lunghezza d’onda, selezionate la scheda «Ottica». Utilizzate il menu a tendina «Lunghezze d’onda» per scegliere una lunghezza d’onda specifica, come mostrato in ??. La visualizzazione 3D si aggiornerà per mostrare solo i raggi corrispondenti alla lunghezza d’onda selezionata.Per analizzare come i percorsi dei raggi dipendono dalla lunghezza d’onda, selezionate la scheda «Ottica». Utilizzate il menu a tendina «Lunghezze d’onda» per scegliere una lunghezza d’onda specifica, come mostrato in ??. La visualizzazione 3D si aggiornerà per mostrare solo i raggi corrispondenti alla lunghezza d’onda selezionata.

Escape from film simulation after running, showing many coloured rays escaping from the rough film.
Dopo aver eseguito la simulazione, la scena si riempie di raggi emessi dal semiconduttore irregolare, che si diffondono in direzione del rivelatore o in direzione opposta.Dopo aver eseguito la simulazione, la scena si riempie di raggi emessi dal semiconduttore irregolare, che si diffondono in direzione del rivelatore o in direzione opposta.
Optical tab showing the wavelength selector used to filter the displayed rays.
La fibra ottica contiene un selettore di lunghezze d’onda. Selezionando una lunghezza d’onda specifica, si filtrano i raggi visualizzati, facilitando lo studio della dipendenza dell’emissione dalla lunghezza d’onda.La fibra ottica contiene un selettore di lunghezze d’onda. Selezionando una lunghezza d’onda specifica, si filtrano i raggi visualizzati, facilitando lo studio della dipendenza dell’emissione dalla lunghezza d’onda.

Passaggio 5: visualizzare i dati di output del rilevatore.Passaggio 5: visualizzare i dati di output del rilevatore.

Una volta completata la simulazione, apri la scheda «Risultati» per visualizzare tutti i file generati dal programma di ray tracing, come mostrato in ??. Il piano del rivelatore nella parte superiore della struttura è identificato con il numero 0, pertanto i relativi risultati vengono salvati in detector0.Una volta completata la simulazione, apri la scheda «Risultati» per visualizzare tutti i file generati dal programma di ray tracing, come mostrato in ??. Il piano del rivelatore nella parte superiore della struttura è identificato con il numero 0, pertanto i relativi risultati vengono salvati in detector0.

Fate doppio clic su detector0 per aprire la finestra di visualizzazione del rivelatore (??). Questo grafico mostra la quantità di luce che passa attraverso il rivelatore in funzione dell'angolo e, nel caso siano state simulate più lunghezze d'onda, in funzione della lunghezza d'onda.Fate doppio clic su detector0 per aprire la finestra di visualizzazione del rivelatore (??). Questo grafico mostra la quantità di luce che passa attraverso il rivelatore in funzione dell'angolo e, nel caso siano state simulate più lunghezze d'onda, in funzione della lunghezza d'onda.

Output tab listing files generated by the Escape from film simulation, including detector0.
La scheda «Output» per la simulazione cinematografica «Escape from». Il file detector0 contiene i risultati ottenuti dal sensore superiore.La scheda «Output» per la simulazione cinematografica «Escape from». Il file detector0 contiene i risultati ottenuti dal sensore superiore.
Detector output plot showing the angular distribution of escaping light.
Esempio di risultati ottenuti con il rilevatore. La mappa cromatica indica la quantità di energia dispersa in funzione dell’angolo (e, se applicabile, della lunghezza d’onda).Esempio di risultati ottenuti con il rilevatore. La mappa cromatica indica la quantità di energia dispersa in funzione dell’angolo (e, se applicabile, della lunghezza d’onda).

Efficienza del rivelatore e immagini elaborate.Efficienza del rivelatore e immagini elaborate.

Il segnale in uscita del rivelatore mostrato in ?? si ottiene facendo doppio clic sul file detector_efficiency0.csv nella scheda «Output». Questo grafico mostra la frazione di luce generata internamente che raggiunge il rivelatore in funzione della lunghezza d’onda, ovvero, in sostanza, l’efficienza di estrazione. In questo esempio, quasi nessuna luce viene emessa a lunghezze d’onda inferiori a circa 600 nm, mentre a lunghezze d’onda maggiori l’efficienza di estrazione aumenta fino a circa il 12%.Il segnale in uscita del rivelatore mostrato in ?? si ottiene facendo doppio clic sul file detector_efficiency0.csv nella scheda «Output». Questo grafico mostra la frazione di luce generata internamente che raggiunge il rivelatore in funzione della lunghezza d’onda, ovvero, in sostanza, l’efficienza di estrazione. In questo esempio, quasi nessuna luce viene emessa a lunghezze d’onda inferiori a circa 600 nm, mentre a lunghezze d’onda maggiori l’efficienza di estrazione aumenta fino a circa il 12%.

Un valore compreso tra il 10 e il 15% è del tutto accettabile per una pellicola con un elevato indice di rifrazione in aria. Per una stima approssimativa, si consideri un'interfaccia piana tra un semiconduttore e l'aria, con indici di rifrazione \(n_{\text{film}}\) e \(n_{\text{air}}\). La riflettanza di Fresnel per incidenza normale è:Un valore compreso tra il 10 e il 15% è del tutto accettabile per una pellicola con un elevato indice di rifrazione in aria. Per una stima approssimativa, si consideri un'interfaccia piana tra un semiconduttore e l'aria, con indici di rifrazione \(n_{\text{film}}\) e \(n_{\text{air}}\). La riflettanza di Fresnel per incidenza normale è:

\( R = \left(\dfrac{n_{\text{film}} - n_{\text{air}}}{n_{\text{film}} + n_{\text{air}}}\right)^2. \) \( R = \left(\dfrac{n_{\text{film}} - n_{\text{air}}}{n_{\text{film}} + n_{\text{air}}}\right)^2. \)

Considerando un tipico semiconduttore o ossido con indici di rifrazione \(n_{\text{film}} \approx 1.8\) e \(n_{\text{air}} = 1.0\), otteniamo \( R \approx 0.08 \) (circa l’8% di riflessione con incidenza normale), quindi la trasmissione è \(1-R \approx 0.92\). Tuttavia, la luce generata all’interno del film può propagarsi solo all’interno del cono di emissione definito dall’angolo critico \( \theta_c = \arcsin\!\bigl(n_{\text{air}}/n_{\text{film}}\bigr) \approx 34^\circ \). Per un’emissione isotropa all’interno del film, la frazione di potenza che si propaga all’interno di questo cono èConsiderando un tipico semiconduttore o ossido con indici di rifrazione \(n_{\text{film}} \approx 1.8\) e \(n_{\text{air}} = 1.0\), otteniamo \( R \approx 0.08 \) (circa l’8% di riflessione con incidenza normale), quindi la trasmissione è \(1-R \approx 0.92\). Tuttavia, la luce generata all’interno del film può propagarsi solo all’interno del cono di emissione definito dall’angolo critico \( \theta_c = \arcsin\!\bigl(n_{\text{air}}/n_{\text{film}}\bigr) \approx 34^\circ \). Per un’emissione isotropa all’interno del film, la frazione di potenza che si propaga all’interno di questo cono è

\( f_{\text{cone}} = 1 - \cos\theta_c \approx 1 - \cos(34^\circ) \approx 0.17. \) \( f_{\text{cone}} = 1 - \cos\theta_c \approx 1 - \cos(34^\circ) \approx 0.17. \)

Moltiplicando i fattori di trasmissione e di dispersione, si ottiene una stima approssimativa dell’efficienza di estrazione.Moltiplicando i fattori di trasmissione e di dispersione, si ottiene una stima approssimativa dell’efficienza di estrazione.

\( \eta_{\text{out}} \approx (1-R)\,f_{\text{cone}} \approx 0.92 \times 0.17 \approx 0.16 \; (16\%). \) \( \eta_{\text{out}} \approx (1-R)\,f_{\text{cone}} \approx 0.92 \times 0.17 \approx 0.16 \; (16\%). \)

Una volta presi in considerazione ulteriori perdite e fenomeni di dispersione, un’efficienza di estrazione di circa il 12%, come si può osservare in detector_efficiency0.csv, risulta quindi un valore del tutto accettabile per questo tipo di struttura.Una volta presi in considerazione ulteriori perdite e fenomeni di dispersione, un’efficienza di estrazione di circa il 12%, come si può osservare in detector_efficiency0.csv, risulta quindi un valore del tutto accettabile per questo tipo di struttura.

Se si fa doppio clic su RAY_image.csv nella stessa cartella, OghmaNano apre un’immagine elaborata che mostra ciò che l’occhio vedrebbe osservando il film, come illustrato in ??. Questo viene calcolato utilizzando lo spazio colore CIE del 1931: il segnale del rivelatore, che varia in base alla lunghezza d’onda, viene convertito in valori di stimolazione tricolore CIE XYZ utilizzando le funzioni standard di corrispondenza dei colori, e quindi mappato su un’immagine sRGB che approssima la percezione visiva umana. Per maggiori dettagli su questo modello di colore, si veda, ad esempio, spazio colore CIE 1931.Se si fa doppio clic su RAY_image.csv nella stessa cartella, OghmaNano apre un’immagine elaborata che mostra ciò che l’occhio vedrebbe osservando il film, come illustrato in ??. Questo viene calcolato utilizzando lo spazio colore CIE del 1931: il segnale del rivelatore, che varia in base alla lunghezza d’onda, viene convertito in valori di stimolazione tricolore CIE XYZ utilizzando le funzioni standard di corrispondenza dei colori, e quindi mappato su un’immagine sRGB che approssima la percezione visiva umana. Per maggiori dettagli su questo modello di colore, si veda, ad esempio, spazio colore CIE 1931.

Detector efficiency vs wavelength plot, showing outcoupling efficiency rising to about 12 percent above 600 nm.
Segnale di uscita del rivelatore ottenuto da detector_efficiency0.csv. Questo grafico mostra l’efficienza di estrazione, che varia in funzione della lunghezza d’onda: rappresenta la frazione di luce generata internamente che raggiunge il rivelatore.Segnale di uscita del rivelatore ottenuto da detector_efficiency0.csv. Questo grafico mostra l’efficienza di estrazione, che varia in funzione della lunghezza d’onda: rappresenta la frazione di luce generata internamente che raggiunge il rivelatore.
Rendered RGB image showing the apparent colour and spatial distribution of light escaping from the rough film.
Immagine resa di RAY_image.csv. Lo spettro del rivelatore è stato convertito in un’immagine a colori reali utilizzando lo spazio cromatico CIE del 1931, in modo da riprodurre approssimativamente ciò che l’occhio umano vedrebbe osservando la pellicola emettente.Immagine resa di RAY_image.csv. Lo spettro del rivelatore è stato convertito in un’immagine a colori reali utilizzando lo spazio cromatico CIE del 1931, in modo da riprodurre approssimativamente ciò che l’occhio umano vedrebbe osservando la pellicola emettente.

👉 Passaggio successivo: proseguite con Parte B per scoprire come modificare la forma della superficie, regolare la sorgente luminosa e importare strutture più complesse nella simulazione «Escape from film». Per una panoramica sui sistemi ottici e sulle simulazioni di ray tracing, consultate Panoramica sui sistemi ottici e sul ray tracing.👉 Passaggio successivo: proseguite con Parte B per scoprire come modificare la forma della superficie, regolare la sorgente luminosa e importare strutture più complesse nella simulazione «Escape from film». Per una panoramica sui sistemi ottici e sulle simulazioni di ray tracing, consultate Panoramica sui sistemi ottici e sul ray tracing.